Workflow TimeOut

Workflow – Executando TimeOut

 

Olá, Seja Bem-vindo!!!

 

Problema com timeout do workflow não estar sendo executado, aberto chamado e segue solução para o mesmo.

 

Erro:

Não executando timeout do workflow após o tempo configurado.

 

Solução:

No .INI adicionar:

[schedulerwf]
Main=WFONSTART
ENVIRONMENT=UNIVERSOADVPL
nParms=4
parm1=99
parm2=01
parm3=UNIVERSOADVPL_WF
parm4=T

 

Workflow TimeOut

Workflow TimeOut

Workflow - Executando TimeOut

Workflow – Executando TimeOut

 

Deixe seu comentário abaixo, assine nossa lista de e-mail e inscreva-se no nosso canal.

Um abraço, e até a próxima.

 

7 respostas
  1. Evaldo
    Evaldo says:

    Olá, fiz um programa para ler algumas informações de tabelas e gerar um arquivo XML para ser gravado em um diretório local. Se executado via menu funciona corretamente a geração do arquivo no diretório indicado, porém quando executo via Schedule não gera o arquivo. Alguém tem alguma ideia do que pode estar errado?

    Segue trecho do código:

    nHdlXml:= FCreate(cAnexo,0)
    If nHdlXml > 0
    FWrite(nHdlXml,cXmlDados)
    FClose(nHdlXml)
    Endif

    Responder
    • Universo ADVPL
      Universo ADVPL says:

      Ola

      Já tentou com apenas uma configuração no .INI e testar nas dois grupos.
      Se o mesmo reconhece automaticamente no retorno o Grupo / Empresa / Filial ?

      Caso não funcione, basta criar duas configuração no mesmo ini == Portal Vendedor.
      Assim:
      [XXX.168.0.XXX:8888/wf01]
      [XXX.168.0.XXX:8888/wf02]

      OK?

      Responder
  2. Carlos Roberto Gomes Junior
    Carlos Roberto Gomes Junior says:

    Boa tarde,

    Estou com esse problema e como ficaria meu .ini

    [ONSTART]
    JOBS=FWSCHDQUEUE_WF,FWSCHDMANAG_WF
    RefreshRate=120

    [FWSCHDMANAG_WF]
    Main=FWSCHDMANAG
    Environment=WF

    [FWSCHDQUEUE_WF]
    Main=FWSCHDQUEUE
    Environment=WF

    Assmin

    [ONSTART]
    JOBS=FWSCHDQUEUE_WF,FWSCHDMANAG_WF
    RefreshRate=120

    [FWSCHDMANAG_WF]
    Main=FWSCHDMANAG
    Environment=WF
    nParms=4
    parm1=99
    parm2=01
    parm3= FWSCHDMANAG_WF
    parm4=T

    [FWSCHDQUEUE_WF]
    Main=FWSCHDQUEUE
    Environment=WF
    nParms=4
    parm1=99
    parm2=01
    parm3= FWSCHDQUEUE_WF
    parm4=T

    Preciso resolver isso com urgência, todos os dias enfrento esse gargalo.

    Att.,

    Responder
    • Universo ADVPL
      Universo ADVPL says:

      [ONSTART]
      JOBS=FWSCHDQUEUE_WF,FWSCHDMANAG_WF,schedule
      RefreshRate=120

      [schedule]
      Main=FWSCHDMANAG
      Environment=AMBIENTE_PRODUCAO
      nParms=4
      parm1=01
      parm2=01
      parm3=AMBIENTE_WORKFLOW
      parm4=T

      Responder
        • Universo ADVPL
          Universo ADVPL says:

          Sim, no .INI deve ter os dois ambientes. Producao e seu Producao_WF.
          Nos ambos APO deve estar compilado os fontes de WF. Isso se for APO diferente nos ambientes.
          No caso aqui, foi o que resolveu.
          Producao_WF pode usar mesmo APO de PRODUCAO, vai de cada um, eu prefiro separar.

          Att,

          Responder

Deixe uma resposta

Want to join the discussion?
Feel free to contribute!

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *